Masking is driving me CRAZY!!!!

Anything & everything relating to ENTTEC DMXIS.
Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Masking is driving me CRAZY!!!!

Post by Brattbugg » Wed Oct 02, 2019 8:15 pm

I cant figure out masking. I have 8 identical par cans all set to individual dmx addresses, they are working flawlessly. I created a new bank called Masked Pars, then presets called Red, Green and Blue. I started with red. I used the disable all channels macro, then double clicked to select all 8 faders for the dimmer and red faders accordingly, I adjusted the values accordingly and went back and saved it by pressing overwrite. Then did the exact same thing for green. but now "red " is green as well. What am I doing wrong?

neilnotts
Posts: 139
Joined: Sun Sep 30, 2012 8:50 am
Location: Nottingham, UK
Contact:

Re: Masking is driving me CRAZY!!!!

Post by neilnotts » Wed Oct 02, 2019 9:28 pm

Hi there. Don't overwrite. Create a new preset each time.
I use masking for everything. For your set up I would first disable all channels, then select and enable all the dimmer channels for your pars. I normally create 2 presets one at zero (off) and one at 100. Next disable all channels again and only select your RGB colour faders. Now you can set them up the same. E. G. All to red then save a red preset. Next fade the red down and set all your blues and so on. I hope that makes sense.

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Wed Oct 02, 2019 10:38 pm

Yeah, not even close to working. I'm ready to throw this thing in the lake

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Wed Oct 02, 2019 10:44 pm

If I am masking 3 different par colors, say red ,blue and green, what faders will stay lit up and which ones will grey out when Im looking at the faders if Ive successfully masked them? In other words, will everything be grey except the dimmer and color fader if I look at them individually?

neilnotts
Posts: 139
Joined: Sun Sep 30, 2012 8:50 am
Location: Nottingham, UK
Contact:

Re: Masking is driving me CRAZY!!!!

Post by neilnotts » Wed Oct 02, 2019 11:02 pm

I tend to keep the rgb colours enabled together but you could isolate each colour if you wish.
Lets say I selected my red preset. Everything except the rgb channels will be greyed out. The reds would be at 100% the blues and greens would be on zero but enabled. If I then select my dimmer 100 preset. Only the dimmer channels would be enabled but the rgb channels from the red preset I selected earlier would still be at their previous settings.

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Wed Oct 02, 2019 11:04 pm

Let me try that

neilnotts
Posts: 139
Joined: Sun Sep 30, 2012 8:50 am
Location: Nottingham, UK
Contact:

Re: Masking is driving me CRAZY!!!!

Post by neilnotts » Wed Oct 02, 2019 11:48 pm

Brattbugg wrote:
Wed Oct 02, 2019 11:04 pm
Let me try that
Any joy? Have a look at this...

https://www.youtube.com/watch?v=0C_3iA0TAiw

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 12:46 am

Gave up for the night. I'll give a go tomorrow. My head can't take it no more

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 3:43 am

Ok here's what I've done, just so I don't mess up what I've already tried to do. I am using 6 channel fixtures, One dimmer channel for each of 6 colors. In DMXIS, I created a new show. Then I created a new bank called masked pars. I pressed preset manager and then macros. I disabled all channels and set faders to zero, I then saved it as zero, meaning everything is off. I went back into preset manager, disabled all channels again, selected red, enabled all selected red channels and brought them up to the desired level, I then disabled the red channels, hit preset manager and hit new, saving it as red. When I go back and hit the zero preset, red lights show up on my fixtures, within the zero preset . Red is present in both presets now. Do you know where I'm making my mistake?

vwodwo22
Posts: 29
Joined: Thu Jul 25, 2019 1:36 am
Location: San Antonio, Texas

Re: Masking is driving me CRAZY!!!!

Post by vwodwo22 » Thu Oct 03, 2019 4:28 am

Just clarifying. The settings for your zero preset basically has all faders set to zero AND all channels are masked(disabled)

If this is the case, this is your problem. When the channel is masked, it will send no signal on that particular channel.

Let’s say you are starting on your zero preset which has all channels masked (sending no values at all). You click on red, and the red channel faders, go to 100. Now, you click on your zero again, and it stays red because as just mentioned the zero preset is not transmitting any information. You need to tell the zero preset to send a 0 value to the red channel to turn it off.

I believe what you are looking at doing is something like this: to keep it simple I’m going to use a three channel as an example. Your channels 1-6 will be unmasked. I do realize this may not be what you intended to do because it sounds like (from what I read) your pars do not have a dimmer which controls the overall light intensity, just 6 channels which controls how much color.

Red Preset
1: red =100
2: green=0
3: blue=0

Zero preset
1: red =0
2: green=0
3: blue=0

When I use masking, it may broken into categories such as colors (red, orange, blue, green, white), dimmers (off, 25, 50, 100, just backlights, just front lights), strobes (none, slow, fast) gobos(star, circles,...) Something like that. It’s really designed to keep you from having to create like a “red no strobe 100 dimmer”, a “red strobe 100 dimmer”, “red no strobe 50 dimmer@, ... and so on. And that’s just one light. Too many possibilities. Would be super confusing.
Last edited by vwodwo22 on Thu Oct 03, 2019 4:45 am, edited 2 times in total.

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 4:42 am

I have the option of having 6 channel or a 10 channel fixture. I was simply using 6 to keep it simple. I would prefer to use 10, then I would have a master fader for each fixture.

vwodwo22
Posts: 29
Joined: Thu Jul 25, 2019 1:36 am
Location: San Antonio, Texas

Re: Masking is driving me CRAZY!!!!

Post by vwodwo22 » Thu Oct 03, 2019 4:47 am

Do you have a link to your lights manual? Or can write what the different channels options are or could be? If it is like RGBAWUv, I’d go the 10 channel route.

PAngell44
Posts: 15
Joined: Tue May 10, 2016 7:20 pm

Re: Masking is driving me CRAZY!!!!

Post by PAngell44 » Thu Oct 03, 2019 6:36 am

This might be a really dumb question, so please don’t laugh.

If your goal is to create a preset for red, and a preset for say, green, why not just create a preset for each? Why do you need to mask?

An example of when I use masking is I might have our front lights running a preset and I want to turn the moving lights on. So I mask the front light fixtures so that when I select the preset to turn the moving lights on, it doesn’t impact the front lights.

If I just wanted to change the front lights to a different preset, I just create that preset. No masking needed.

I must be missing something in the explanation of what you are trying to do.

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 11:10 am

Yes, I want to add extra lights for icing. In addition to the front truss of pars, I have movers and foggers that I'd like to kick on every so often.

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 11:15 am

vwodwo22 wrote:
Thu Oct 03, 2019 4:47 am
Do you have a link to your lights manual? Or can write what the different channels options are or could be? If it is like RGBAWUv, I’d go the 10 channel route.
10ch is
1- dimmer
2- strobe
3- function
4- color change
5-red
6-green
8-blue
8-white
9-amber
10-uv

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 1:36 pm

Would you be able to tell me what the screens should look like for masked blackout, red, blue and green presets? Please tell me what should be disabled(greyed out) , enabled and what the values should look like. I think if I could see it I would have a better understanding of how this works. I would prefer to use the 10channel setting on my lights. Anyone who can help me, I would appreciate it beyond belief.

vwodwo22
Posts: 29
Joined: Thu Jul 25, 2019 1:36 am
Location: San Antonio, Texas

Re: Masking is driving me CRAZY!!!!

Post by vwodwo22 » Thu Oct 03, 2019 3:23 pm

This Is how I would do it. But your setup may dictate a need for something else. What we are doing is isolating your colors, dimmers, and strobes

Full Dimmer
1- dimmer (100)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (masked)
6-green (masked)
8-blue (masked)
8-white(masked)
9-amber(masked)
10-uv (masked)

Dimmers Off Preset (Blackout)
1- dimmer (0)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (masked)
6-green (masked)
8-blue (masked)
8-white(masked)
9-amber(masked)
10-uv (masked)

Red Preset
1- dimmer (masked)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (100)
6-green (0)
8-blue (0)
8-white(0)
9-amber(0)
10-uv (0)

Green Preset
1- dimmer (masked)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (0)
6-green (100)
8-blue (0)
8-white(0)
9-amber(0)
10-uv (0)

Blue Preset
1- dimmer (masked)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (0)
6-green (0)
8-blue (100)
8-white(0)
9-amber(0)
10-uv (0)

Purple Preset
1- dimmer (masked)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (100)
6-green (0)
8-blue (100)
8-white(0)
9-amber(0)
10-uv (0)

Strobe On Preset
1- dimmer (Masked)
2- strobe (50, 75, or 100. To your liking really)
3- function (masked)
4- color change (masked)
5-red (masked)
6-green (masked)
8-blue (masked)
8-white(masked)
9-amber(masked)
10-uv (masked)

Strobes Off Preset
1- dimmer (Masked)
2- strobe (0)
3- function (masked)
4- color change (masked)
5-red (masked)
6-green (masked)
8-blue (masked)
8-white(masked)
9-amber(masked)
10-uv (masked)

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 3:36 pm

vwodwo22 wrote:
Thu Oct 03, 2019 3:23 pm
This Is how I would do it. But your setup may dictate a need for something else. What we are doing is isolating your colors, dimmers, and strobes

Full Dimmer
1- dimmer (100)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (masked)
6-green (masked)
8-blue (masked)
8-white(masked)
9-amber(masked)
10-uv (masked)

Dimmers Off Preset (Blackout)
1- dimmer (0)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (masked)
6-green (masked)
8-blue (masked)
8-white(masked)
9-amber(masked)
10-uv (masked)

Red Preset
1- dimmer (masked)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (100)
6-green (0)
8-blue (0)
8-white(0)
9-amber(0)
10-uv (0)

Green Preset
1- dimmer (masked)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (0)
6-green (100)
8-blue (0)
8-white(0)
9-amber(0)
10-uv (0)

Blue Preset
1- dimmer (masked)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (0)
6-green (0)
8-blue (100)
8-white(0)
9-amber(0)
10-uv (0)

Purple Preset
1- dimmer (masked)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (100)
6-green (0)
8-blue (100)
8-white(0)
9-amber(0)
10-uv (0)

Strobe On Preset
1- dimmer (Masked)
2- strobe (50, 75, or 100. To your liking really)
3- function (masked)
4- color change (masked)
5-red (masked)
6-green (masked)
8-blue (masked)
8-white(masked)
9-amber(masked)
10-uv (masked)

Strobes Off Preset
1- dimmer (Masked)
2- strobe (0)
3- function (masked)
4- color change (masked)
5-red (masked)
6-green (masked)
8-blue (masked)
8-white(masked)
9-amber(masked)
10-uv (masked)
So this is super helpful!
What I'm seeing here is that going from one color to the next, all colors need to be unmasked. Red will have a value for red but no values on the other colors, however the fader will be available (by being unmasked) so the light can react to the color change. The dimmer stays masked so it is always on from one color to the next, except in the case of blackout. Am I understanding it correctly? Lord please say yes!

vwodwo22
Posts: 29
Joined: Thu Jul 25, 2019 1:36 am
Location: San Antonio, Texas

Re: Masking is driving me CRAZY!!!!

Post by vwodwo22 » Thu Oct 03, 2019 4:18 pm

Sounds like you got it!

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 4:27 pm

Cool. Out of curiosity what do you use the full dimmer preset for? Also, the strobes, I don't see color in your example.

vwodwo22
Posts: 29
Joined: Thu Jul 25, 2019 1:36 am
Location: San Antonio, Texas

Re: Masking is driving me CRAZY!!!!

Post by vwodwo22 » Thu Oct 03, 2019 5:07 pm

Full Dimmers= Turn lights on 100%
Dimmers Off = Turn Lights Off
same with strobes

Let's pretend we are doing a show.

1. Activate "Full Dimmer" preset, dimmers are set to high, but no color is being sent because we haven't sent a color yet)
2. The I click, "Red "preset, and my lights show up red.
3. The I click "Blue", preset and my lights go blue.
4. Crazy part of the song coming up so I hit the, "Strobes On" preset. (because our lights are on "Blue", they will strobe blue)
5. The I click, "Red "preset, and my lights show up red. (still strobing because we haven't turned "strobe off" yet, but lights now strobe "red")
6. Crazy part ends, so I hit "Strobes Off" preset. (now lights are just solid red)
7. Song ends, I hit "Dimmers Off" and lights go off


You could also create a "Dimmers 50" or "Dimmers 75" or "Dimmers 10". Something like that

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 5:20 pm

So since I'm also using show buddy, do I need to put the full dimmer and such in the timeline as well?

vwodwo22
Posts: 29
Joined: Thu Jul 25, 2019 1:36 am
Location: San Antonio, Texas

Re: Masking is driving me CRAZY!!!!

Post by vwodwo22 » Thu Oct 03, 2019 6:03 pm

In short, and assuming you set up things as I described, yes. Just at the beginning of the song. It's not always necessary, but say for example you end a song and with the lights off. If you start the next song and don't have the "Dimmer On" activated, it wont show any lights.

FYI, because I am not that familiar with SB some of the info may be wrong, but general practice not a bad idea.

I'm Actually using show buddy active but, there are a couple of options, and really depends on how you want to run your show. Meaning, a solo light guy will likely setup things different than a band, who may set their stuff up different than a dj. (really a lot of things to consider). For me, I'm in a band and its being controlled by Ableton live. (trying out SBA live for first time on 10/19/2019) For this particular setup, I don't actually use the masking and just program full scenes with dimmer info included. Now, if I'm helping a DJ buddy out and doing lights, I will program a couple dozen scenes (with masking) and should be good to go.

Are you in a band, DJ, how are you looking at controlling this? That should be taken into consideration.

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 6:14 pm

I'm in a band. No light guy. We have tracks for every song, even if it's just a click track. Our drummer triggers the tracks. I havent used this program yet, just getting into it. Up till now, we have tracks on a tablet and lights set to auto pilot. My initial thought was to build a front truss light show that can be used as a basic show when we play anywhere. Then, when shows are bigger, add moving heads and fog units. My thought was to add these extras by using momentary cues to trigger them since they are not always on. But the front truss needs to be on all the time, hence the need for masking. Am I on the right track?

vwodwo22
Posts: 29
Joined: Thu Jul 25, 2019 1:36 am
Location: San Antonio, Texas

Re: Masking is driving me CRAZY!!!!

Post by vwodwo22 » Thu Oct 03, 2019 7:33 pm

Your situation is very similar to mine. In a band, I (guitar player) get the track started and we use backing/click tracks. I would say since your front truss will always be on, you can unmask the dimmer for your color presets (if you wanted. Really wont matter much in your case. See below). That way your front truss lights will not go out. And since your looking at adding stuff, mask out all the channels that do not belong to the lights on the front truss (as you are doing now).

Red Preset w/dimmer
1- dimmer (100)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (100)
6-green (0)
8-blue (0)
8-white(0)
9-amber(0)
10-uv (0)

If you only had one light, mask channel 11-512

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 7:38 pm

vwodwo22 wrote:
Thu Oct 03, 2019 7:33 pm
Your situation is very similar to mine. In a band, I (guitar player) get the track started and we use backing/click tracks. I would say since your front truss will always be on, you can unmask the dimmer for your color presets (if you wanted. Really wont matter much in your case. See below). That way your front truss lights will not go out. And since your looking at adding stuff, mask out all the channels that do not belong to the lights on the front truss (as you are doing now).

Red Preset w/dimmer
1- dimmer (100)
2- strobe (masked)
3- function (masked)
4- color change (masked)
5-red (100)
6-green (0)
8-blue (0)
8-white(0)
9-amber(0)
10-uv (0)

If you only had one light, mask channel 11-512
If I unmask to dimmer on the colors, will blackout still work then? I use black out a bunch so far. By the way, where are you located?

vwodwo22
Posts: 29
Joined: Thu Jul 25, 2019 1:36 am
Location: San Antonio, Texas

Re: Masking is driving me CRAZY!!!!

Post by vwodwo22 » Thu Oct 03, 2019 7:55 pm

Yes. It will until another color patch kicks in. If your going to be blacking out the front truss periodically, I would not include the dimmer in with your color preset. If it will constantly stay on, I would. San Antonio, Texas

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Thu Oct 03, 2019 8:03 pm

Thank you so much for the help, gonna put it all to use in a few minutes here. This is my band www.atomicradioband.com
I'm the bass player.

vwodwo22
Posts: 29
Joined: Thu Jul 25, 2019 1:36 am
Location: San Antonio, Texas

Re: Masking is driving me CRAZY!!!!

Post by vwodwo22 » Thu Oct 03, 2019 8:15 pm

Nice. Sounds good and good song selections! Let m know how it goes

Brattbugg
Posts: 32
Joined: Wed Sep 18, 2019 11:51 am
Location: Detroit Michigan, USA

Re: Masking is driving me CRAZY!!!!

Post by Brattbugg » Fri Oct 04, 2019 1:59 am

Since I'm going to be triggering 2 moving heads and 2 fog machines here and there, do I need do mask them to completely in the front truss presets? Set everything on the foggers and movers to zero? Then when I set them up, I need to mask the front truss pars on the new presets as well, correct?

Post Reply